实验目的:

1、掌握EIGRP的基本配置。

2.掌握EIGRP的邻居表、拓扑表、路由表。

3.掌握EIGRP的无类特性。

实验拓扑:

实验步骤:

1、依据图中拓扑配置各设备的IP地址,并保证直连连通性;

在R1上做如下配置:

R1(config)#int f0/0

R1(config-if)#no shutdown

R1(config-if)#ip address 12.1.1.1 255.255.255.0

R1(config-if)#exit

R1(config)#int f1/0

R1(config-if)#no shutdown

R1(config-if)#ip address 13.1.1.1 255.255.255.0

R1(config-if)#exit

R1(config)#int loopback 1

R1(config-if)#ip address 1.1.1.1 255.255.255.255

R1(config-if)#exit

在R2上做如下配置:

R2(config)#int f0/0

R2(config-if)#no shutdown

R2(config-if)#ip address 12.1.1.2 255.255.255.0

R2(config-if)#exit

R2(config)#int f1/0

R2(config-if)#no shutdown

R2(config-if)#ip address 23.1.1.2 255.255.255.0

R2(config-if)#exit

R2(config)#int loopback 1

R2(config-if)#ip address 2.2.2.2 255.255.255.255

R2(config-if)#exit

在R3上做如下配置:

R3(config)#int f0/0

R3(config-if)#no shutdown

R3(config-if)#ip address 13.1.1.3 255.255.255.0

R3(config-if)#exit

R3(config-if)#int f1/0

R3(config-if)#no shutdown

R3(config-if)#ip address 23.1.1.3 255.255.255.0

R3(config-if)#exit

R3(config)#int loopback 1

R3(config-if)#ip address 3.3.3.3 255.255.255.255

R3(config-if)#exit

在其中一台路由器上进行连通性测试:

R1#ping 12.1.1.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 12.1.1.2, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 20/34/48 ms

R1#ping 13.1.1.3


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 13.1.1.3, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 16/31/48 ms

此时说明直连连接没有问题。

2.在每台路由器开始进行EIGRP的配置,R1的配置如下:

R1(config)#router eigrp 100

R1(config-router)#no auto-summary 

R1(config-router)#network 12.1.1.0 0.0.0.255  

R1(config-router)#network 13.1.1.0 0.0.0.255

R1(config-router)#network 1.1.1.1 0.0.0.0

R1(config-router)#exit

R2的配置如下:

R2(config)#router eigrp 100

R2(config-router)#no auto-summary

R2(config-router)#network 12.1.1.0 0.0.0.255

R2(config-router)#network 23.1.1.0 0.0.0.255

R2(config-router)#network 2.2.2.2 0.0.0.0

R2(config-router)#exit

R3的配置如下:

R3(config)#router eigrp 100

R3(config-router)#no auto-summary

R3(config-router)#network 13.1.1.0 0.0.0.255

R3(config-router)#network 23.1.1.0 0.0.0.255

R3(config-router)#network 3.3.3.3 0.0.0.0

R3(config-router)#exit

3、查看EIGRP的邻居表、拓扑表和路由表,在R1上查看EIGRP邻居表,

如下:

R1#show ip eigrp neighbors

IP-EIGRP neighbors for process 100

H   Address     Interface    Hold Uptime   SRTT   RTO  Q  Seq

                             (sec)            (ms)        Cnt  Num

1    13.1.1.3       Fa1/0      11  00:03:45    74     444   0   11

0    12.1.1.2       Fa0/0      14  00:04:10    65     390   0   10

其中H表示与其他路由器建立邻居的顺序,Address表示邻居的IP地址,Interface表示本地接口,Hold表示holdtime,默认为15s。从这里可以看到R1与R2和R3依次建立了邻居关系。

在R1上查看EIGRP拓扑表,如下:

R1#show ip eigrp topology

IP-EIGRP Topology Table for AS(100)/ID(1.1.1.1)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status


P 3.3.3.3/32, 1 successors, FD is 156160

        via 13.1.1.3 (156160/128256), FastEthernet1/0

P 2.2.2.2/32, 1 successors, FD is 156160

        via 12.1.1.2 (156160/128256), FastEthernet0/0

P 1.1.1.1/32, 1 successors, FD is 128256

        via Connected, Loopback1

P 12.1.1.0/24, 1 successors, FD is 28160

        via Connected, FastEthernet0/0

P 13.1.1.0/24, 1 successors, FD is 28160

        via Connected, FastEthernet1/0

P 23.1.1.0/24, 2 successors, FD is 30720

        via 13.1.1.3 (30720/28160), FastEthernet1/0

        via 12.1.1.2 (30720/28160), FastEthernet0/0

此命令放置满足FC<可行条件>的路由条目,若想查看所有EIGRP的路由条目,则需要加入all-links参数:

R1#show ip eigrp topology all-links

IP-EIGRP Topology Table for AS(100)/ID(1.1.1.1)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - reply Status, s - sia Status


P 3.3.3.3/32, 1 successors, FD is 156160, serno 8

        via 13.1.1.3 (156160/128256), FastEthernet1/0

        via 12.1.1.2 (158720/156160), FastEthernet0/0

P 2.2.2.2/32, 1 successors, FD is 156160, serno 5

        via 12.1.1.2 (156160/128256), FastEthernet0/0

        via 13.1.1.3 (158720/156160), FastEthernet1/0

P 1.1.1.1/32, 1 successors, FD is 128256, serno 3

        via Connected, Loopback1

P 12.1.1.0/24, 1 successors, FD is 28160, serno 1

        via Connected, FastEthernet0/0

P 13.1.1.0/24, 1 successors, FD is 28160, serno 2

        via Connected, FastEthernet1/0

P 23.1.1.0/24, 2 successors, FD is 30720, serno 7

        via 13.1.1.3 (30720/28160), FastEthernet1/0

        via 12.1.1.2 (30720/28160), FastEthernet0/0

此时在查看R1上的路由表,如下:

R1#show ip route eigrp

     2.0.0.0/32 is subnetted, 1 subnets

D       2.2.2.2 [90/156160] via 12.1.1.2, 00:08:48, FastEthernet0/0 

     3.0.0.0/32 is subnetted, 1 subnets

D       3.3.3.3 [90/156160] via 13.1.1.3, 00:08:47, FastEthernet1/0

     23.0.0.0/24 is subnetted, 1 subnets

D       23.1.1.0 [90/30720] via 13.1.1.3, 00:08:50, FastEthernet1/0

                 [90/30720] via 12.1.1.2, 00:08:50, FastEthernet0/0

可以看到,R1已经通过EIGRP协议从其他路由器学习到EIGRP路由,此时可以进行测试,如下:

R1#ping 2.2.2.2 source 1.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/33/48 ms


R1#ping 3.3.3.3 source 1.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/37/48 ms

此时,R1可以与R2和R3的环回网段进行通信;同样的方法在R2和R3上进行测试,此实验完成。