实验目的:

1、掌握帧中继上部署RIPv2。

2、通过部署RIPv2实现不同分支之间的通信。

实验拓扑:

实验步骤:

1、依据图中拓扑,通过路由器模拟帧中继交换机,配置如下:

①开启帧中继交换功能

FW-SW(config)#frame-relay switching

②接口开启帧中继封装,并定义为DCE接口

FW-SW(config)#int s0/0

FW-SW(config-if)#no shutdown

FW-SW(config-if)#encapsulation frame-relay

FW-SW(config-if)#frame-relay intf-type dce

FW-SW(config-if)#exit

FW-SW(config)#int s0/1

FW-SW(config-if)#no shutdown

FW-SW(config-if)#encapsulation frame-relay

FW-SW(config-if)#frame-relay intf-type dce

FW-SW(config-if)#exit

FW-SW(config)#int s0/2

FW-SW(config-if)#no shutdown

FW-SW(config-if)#encapsulation frame-relay

FW-SW(config-if)#frame-relay intf-type dce

FW-SW(config-if)#exit

③编写帧中继转发条目

FW-SW(config)#int s0/0

FW-SW(config-if)#frame-relay route 102 interface s0/1 201

FW-SW(config-if)#frame-relay route 103 interface s0/0 301

FW-SW(config-if)#exit

FW-SW(config)#int s0/1

FW-SW(config-if)#frame-relay route 201 interface s0/0 102

FW-SW(config-if)#exit

FW-SW(config)#int s0/2

FW-SW(config-if)#frame-relay route 301 interface s0/0 103

FW-SW(config-if)#exit

2、通过部署帧中继技术,使得各个站点直连连通,其中R1为中心点,R2和R3为分支点,配置如下:

R1上

R1(config)#int s0/0     

R1(config-if)#no shutdown

R1(config-if)#encapsulation frame-relay

R1(config-if)#no frame-relay inverse-arp

R1(config-if)#frame-relay map ip 192.168.1.2 102 broadcast

R1(config-if)#frame-relay map ip 192.168.1.3 103 broadcast

R1(config-if)#exit

R2上

R2(config)#int s0/0

R2(config-if)#no shutdown

R2(config-if)#encapsulation frame-relay

R2(config-if)#no frame-relay inverse-arp

R2(config-if)#frame-relay map ip 192.168.1.1 201 broadcast

R2(config-if)#frame-relay map ip 192.168.1.3 201 broadcast

R2(config-if)#exit

R3上

R3(config)#int s0/0

R3(config-if)#no shutdown

R3(config-if)#encapsulation frame-relay

R3(config-if)#no frame-relay inverse-arp

R3(config-if)#frame-relay map ip 192.168.1.1 301 broadcast

R3(config-if)#frame-relay map ip 192.168.1.2 301 broadcast

R3(config-if)#exit

测试直连连通性,如下:

R1#ping 192.168.1.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/42/60 ms

R1#ping 192.168.1.3


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/31/52 ms

R2#ping 192.168.1.3


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 44/68/96 ms

可以看到,直连连通没有问题。

3、部署RIPv2路由协议,使得不同分支之间能够相互通信,配置如下:

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no auto-summary

R1(config-router)#network 1.0.0.0

R1(config-router)#network 192.168.1.0

R1(config-router)#exit


R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 2.0.0.0

R2(config-router)#network 192.168.1.0

R2(config-router)#exit


R3(config)#router rip

R3(config-router)#version 2

R3(config-router)#no auto-summary

R3(config-router)#network 3.0.0.0

R3(config-router)#network 192.168.1.0

R3(config-router)#exit

查看路由表,如下:

R1#show ip route rip

     2.0.0.0/32 is subnetted, 1 subnets

R       2.2.2.2 [120/1] via 192.168.1.2, 00:00:01, Serial0/0

     3.0.0.0/32 is subnetted, 1 subnets

R       3.3.3.3 [120/1] via 192.168.1.3, 00:00:17, Serial0/0


R2#show ip route rip

     1.0.0.0/32 is subnetted, 1 subnets

R       1.1.1.1 [120/1] via 192.168.1.1, 00:00:15, Serial0/0

     3.0.0.0/32 is subnetted, 1 subnets

R       3.3.3.3 [120/2] via 192.168.1.3, 00:00:15, Serial0/0


R3#show ip route rip

     1.0.0.0/32 is subnetted, 1 subnets

R       1.1.1.1 [120/1] via 192.168.1.1, 00:00:18, Serial0/0

     2.0.0.0/32 is subnetted, 1 subnets

R       2.2.2.2 [120/2] via 192.168.1.2, 00:00:18, Serial0/0

可以看到,全局路由信息已经同步,测试连通性,如下:

R1#ping 2.2.2.2 source 1.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/52/80 ms

R1#ping 3.3.3.3 source 1.1.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

Packet sent with a source address of 1.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/25/36 ms

R2#ping 3.3.3.3 source 2.2.2.2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:

Packet sent with a source address of 2.2.2.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/52/84 ms

测试成功,说明在帧中继上部署RIPv2可以实现不同分支互联。但是需要提醒一点,默认情况下,运行RIPv2时,接口下关闭水平分割,如下:

R1#show ip interface s0/0

Serial0/0 is up, line protocol is up

  Internet address is 192.168.1.1/24

  Broadcast address is 255.255.255.255

  Address determined by non-volatile memory

  MTU is 1500 bytes

  Helper address is not set

  Directed broadcast forwarding is disabled

  Multicast reserved groups joined: 224.0.0.9

  Outgoing access list is not set

  Inbound  access list is not set

  Proxy ARP is enabled

  Local Proxy ARP is disabled

  Security level is default

  Split horizon is disabled

……

若水平分割开启,则分支之间的路由信息学习会出现问题,在之后的实验中有解答。此实验完成。